Line 6 FBV™ Control Application
Basic User Guide

FBV Shortboard™ & Express™ MkII Controllers
Mac® OS X, Windows® XP® & Windows® Vista®
# Table of Contents

## Getting Started

- System Requirements ........................................................................................................... 1.1
- The Line 6 FBV™ Control Installer ..................................................................................... 1.1
- Connect Your FBV MkII ....................................................................................................... 1.2
- Take Control .......................................................................................................................... 1.4

## Line 6 FBV Control Overview

- What's in it for Me? ............................................................................................................... 2.1
- Graphical User Interface ....................................................................................................... 2.1
- Opening and Saving FBV Presets ......................................................................................... 2.5
- Preferences ............................................................................................................................. 2.6

## Using Your FBV with Software Applications

- About USB MIDI Ports & Channels .................................................................................. 3.1
- Line 6 GearBox Control ....................................................................................................... 3.2
- Controlling 3rd Party MIDI/DAW Software ........................................................................ 3.3

## Line 6 Monkey & Additional Resources

- Login Account ....................................................................................................................... 4.1
- Register Your Hardware ......................................................................................................... 4.1
- Grab Those Updates .............................................................................................................. 4.2
- Additional Resources ............................................................................................................ 4.2

---

Line 6, FBV, FBV Shortboard MkII, FBV Express MkII, POD, POD Studio, TonePort, GearBox, Spider IV, Line 6 Monkey, are trademarks of Line 6, Inc. All other product names, trademarks, and artists’ names are the property of their respective owners, which are in no way associated or affiliated with Line 6.

Copyright © 2009 Line 6, Inc.
**GETTING STARTED**

Congratulations if you’ve purchased one of the Line 6 FBV Shortboard™ MkII or FBV Express™ MkII Series Controller devices! The Line 6 FBV Control application is designed to run on your Mac® or Windows® computer to provide you the ability to create and customize your FBV MkII device’s USB MIDI software control capabilities. This document will walk you through the basics for downloading, installing and configuring the Line 6 FBV Control software on your Mac® or Windows® computer. Let’s get started...

This **Basic User Guide** is designed to get you up and running in a snap. For more details on using your Line 6 FBV MkII device as a USB MIDI software controller, or with Line 6 POD X3 hardware & Spider IV amps please be sure to go to the [FBV MkII Online Help](#) site and download the FBV MkII and Spider IV Advanced User Guides!

**System Requirements**

We recommend that you read the separate, **Line 6 FBV Control Release Notes** document for the full, detailed System Requirements, as well as up-to-date info on compatibility with other hardware and software. This document can be found within the [Line 6 Support Community](#) or on the [FBV MkII Online Help](#) page.

Line 6 FBV Control supports the following computer operating systems:

- Windows® XP® Home or Professional, with Service Pack 2 (or later), 32 and 64 bit versions
- Windows® Vista® Home, Business or Ultimate Edition, 32 and 64 bit versions
- Mac® OS X 10.4.x (Tiger®)
- Mac® OS X 10.5.x (Leopard®)

**Note to Windows® Vista® users:** It is not recommended that you exit Vista using the Sleep mode while you have the Line 6 FBV Control application running, or with your FBV connected to your USB port. Due to the inherent behavior of Vista’s USB Class Compliant driver, some USB devices (such as FBV) will not properly initialize when resuming from Sleep mode.

**Line 6 Software Compatibility**

At this time, POD Farm™ 1.1 does not provide support for MIDI control. If you want to use your FBV MkII hardware to control the Line 6 GearBox™ software, you’ll want to install the GearBox 3.7 version (or later) for best performance. To get the latest GearBox version, connect your Line 6 USB audio device you’ll be using with GearBox (POD Studio™, TonePort™ or GuitarPort™ hardware) and launch [Line 6 Monkey](#), or go directly to the [Line 6 Software Downloads](#) page and choose “GearBox”.

**The Line 6 FBV™ Control Installer**

If you have not already installed the Line 6 FBV™ Control application, then you’ll need to obtain the free installer for your Mac® or Windows® computer. You can get it by using Line 6 Monkey, or directly from the [Line 6 Software Downloads](#) site.

For more details on Line 6 Monkey, check out “[Line 6 Monkey & Additional Resources](#)” on page 4•1.
If you already have Line 6 Monkey software utility installed on your computer...

Connect your Line 6 FBV MkII device to your Mac® or Windows® computer's USB port and launch Line 6 Monkey. This will scan your system and point you to the latest Line 6 FBV Control installer (as well as any other recommended updates). Select the Line 6 FBV Control application within Line 6 Monkey's Updates page and it will walk you through downloading the software, and launching the installer. Simply follow the steps in the Line 6 FBV Control installer.

If you do not have Line 6 Monkey software utility installed on your computer...

You can get the latest Line 6 FBV Control application installer for free by going to www.line6.com/software. Be sure to choose your specific FBV MkII device from the Product selector, “Line 6 FBV Control” from the Software selector, and the specific Mac® or Windows® operating system version your computer uses from the OS selector. Once downloaded, just run the installer, following the steps along the way.

The Line 6 FBV Control installer will also install the latest Line 6 Monkey version - it is not necessary for you to download these items separately. Note that there is no special USB device driver software needed to be installed for your FBV MkII hardware - Just connect the USB cable to your Mac® or Windows® computer and your operating system will automatically detect it as a new USB device.

Note to Windows® XP® users: You may see that Windows® XP® recognizes your FBV MkII as “USB Audio Device”. This is normal and just kind of a strange behavior inherent to the Windows® Class Compliant USB driver. No worries - Your FBV will work just fine as a USB MIDI device!

To Uninstall Line 6 FBV Control

Should you ever need to remove the application from your computer, just follow these steps:

- **Mac®** - Open the Finder and browse to the Applications > Line 6 directory. Just drag the Line 6 FBV Control application to your Trash to remove it.
- **Windows®** - Go to Start > Programs > Line 6 > Tools and select the Line 6 Uninstaller utility. This handy application walks you through removing several Line 6 applications and device drivers. You’ll have the option to choose to Line 6 FBV Control in the process.

Connect Your FBV MkII

The first time you connect your FBV Shortboard/Express MkII device to your computer’s USB port, your Mac® or Windows® operating system needs to install a device driver to allow your FBV to work with other hardware and software on your computer. On a Mac® or Windows® Vista® computer, this process is done automatically, and you can skip to the next section to put your FBV to use.

On Windows® XP®, you’ll need to click through a few dialogs to install the device driver. Once you connect the USB cable, you should see Windows® XP® detect the new device at the bottom right of your screen:
Next, the Windows Hardware Wizard will launch. Select “No, not this time” then click Next.

In the following screen, select the “Install automatically” option and click Next.

Note that Windows XP recognizes FBV MkII as a “USB Audio Device”. This is correct behavior since it is using the Windows Class Compliant USB driver.

Next you should see the final dialog telling the installation is complete - click Finish. Your FBV is now ready to rock!
Take Control

With your FBV MkII device connected to your computer's USB port, launch the Line 6 FBV Control application. You can launch it from the desktop shortcut, or find the program here:

- **Mac**® - Applications > Line 6 > Line 6 FBV Control
- **Windows**® - Start > Programs > Line 6 > FBV > Line 6 FBV Control

Once launched, you'll be presented with the following informational dialog...

This is an important Line 6 FBV Control application behavior for you to be aware of, so please read the message in this dialog! Your FBV MkII device stores one FBV preset within its internal memory at all times, and this internal FBV memory is automatically updated whenever you edit any setting in the Line 6 FBV Control application with your FBV connected. This makes it super easy to change a few settings to customize your FBV MkII controller behaviors. You can also backup your current preset, or create as many additional customized FBV presets as you like, and store them on your computer's hard drive. Please see “Opening and Saving FBV Presets” on page 2•5 for details. Click OK to proceed.

The Line 6 FBV Control application will now automatically load the FBV preset from the internal memory of your connected FBV Shortboard™ or Express™ MkII device. The Control assignments that make up this FBV patch will be displayed in the application's interface. Your FBV MkII device functions as a standard USB - MIDI external controller device to communicate with any software on your computer that responds to the common types of MIDI control messages (MIDI CC, Bank & Program Change, MIDI Machine Control or Mackie Control message types). No need to go learn all about the intricate workings of MIDI to get things working though - you can simply start off with your current FBV settings, or by loading an FBV preset... Read on.

**FBV Presets**

Your FBV MkII device comes pre-loaded with a full set of MIDI assignments, and you'll see these settings load into the FBV Control application's Control Properties list when you launch it. You can get started controlling your software with these settings, or select one of the FBV preset “patches” we've provided. An FBV preset consists of a set of “controller assignments” for your FBV Shortboard™ or Express™ MkII device, each of which can be a MIDI message assigned to any individual control on your hardware. Just select File > Open within the Line 6 FBV Control application and select an existing FBV Preset (.fbv) file. These presets are found here:

- **Mac**® - Documents > Line 6 > FBV > Presets
- **Windows**® - My Documents > Line 6 > FBV > Presets
The “FBV-Default.fbv” preset that you'll see in the above directories is actually the same set of assignments that your FBV comes loaded with new. So, should you ever want to return your FBV back to these settings, simply load this preset.

When you launch the actual software you want to control, typically you'll need go to that application's Options or Preferences and choose the “Line 6 FBV MIDI Port 1” as an external MIDI controller device. For example, in the GearBox software, just go to the Preferences > MIDI/Control page and select your FBV MkII as the “MIDI Input” option.

Most MIDI and DAW software applications utilize the types of MIDI commands supported by your FBV and Line FBV Control application. However, most applications configure their own specific MIDI assignments to access their parameters, banks and programs. You'll want to consult your MIDI/DAW software's documentation to find its specific MIDI Control settings. The “Using Your FBV with Software Applications” on page 3•1 provides more tips for configuring your FBV for controlling 3rd party software.

Please proceed to the next chapter for an overview of the Line 6 FBV Control User Interface and features. For more details, be sure to also grab the FBV MkII Advanced User Guide and other documentation found on the FBV MkII Online Help page.
Line 6 FBV Control Overview

The previous Getting Started Chapter should have already gotten you up and running with your FBV MkII controller. In this chapter, we'll provide you with an overview of the features and functions found in the Line 6 FBV Control application's user interface.

What's in it for Me?

Your new FBV Shortboard™ or Express™ MkII is a pretty sophisticated piece of gear, capable of controlling not only Line 6 Amp and POD® devices (via an RJ-45 cable connection), but also capable of controlling any software on your computer that receives common MIDI control messages (via a standard USB connection). The Line 6 FBV Control application is specifically for the latter function. It provides a simple yet powerful set of features to allow you create and customize specifically what type of MIDI message is sent from each of the footswitch and pedal controls to your desired software. Further, you can then store these control assignments as FBV Preset files, stored on your computer for recall anytime. Go ahead and tweak all you like to allow your FBV MkII hardware to do all those naughty MIDI controller things you always wanted to try!

Graphical User Interface

In software speak, the main window of the Line 6 FBV Control application is referred to as the "Graphical User Interface" (or "GUI" if you want to sound hip around your software buddies). Here we've laid out descriptions for all the important things you need to know as you start clicking around in there. Refer to the numbered descriptions below for details.
Device Controls

1 - FBV Image: A graphical image of your selected FBV MkII device is displayed here. To edit the MIDI assignment for any control on your FBV, click directly on the footswitch or pedal in this image, or on the corresponding row in the Control Properties list below to select it. See the Control Properties List description for edit options.

Note: The FBV Control application will automatically detect and select your USB-connected FBV device (Shortboard or Express MkII). However, you have some other options when launching with no FBV device or multiple FBV devices connected. See the Preferences section for details.

2 - Footswitches: Click directly on any footswitch here to select it and its related row in the Control Properties List, where you can edit its MIDI assignment. All footswitches on your FBV MkII hardware can be set to send any type of MIDI settings available in the Control Parameter list’s columns, regardless of how the footswitch is labeled on your FBV hardware chassis. You’ll see the LED on the top portion of each footswitch on your FBV light up as you press it to indicate the MIDI Command is being sent. When the Switch Mode option for the footswitch is set to “Toggle” you’ll see the LED alternate between staying lit and unlit, corresponding to the alternating two switch behaviors that are sent on each successive press.

Note: These LED behaviors are based strictly on the footswitch control settings, as configured in the Control Properties list. The FBV MkII device does not respond to MIDI data from your MIDI or DAW software.

3 - Pedal Wah and Vol: These provide you with two assignable functions for your FBV on-board pedal (referred to as “Pedal 1”). To edit the assignments for these Pedal 1 functions, click directly on the WAH or VOL indicator items in the image, respectively (or directly on their rows in the Control Properties list). You can assign each of these Pedal 1 functions to send any MIDI CC value you like so you can toggle between controlling two different parameters in your software by pressing the pedal full forward and clicking the Toe Switch. Also see the next description about the Toe Switch for related functions. When the WAH LED is lit on your FBV hardware, this indicates that the Pedal 1 “Wah” assignment is in use. When VOL LED is lit, this indicates Pedal 1 “Vol” assignment is in use.

4 - Pedal 1 Toe Switch: Click here to select the “Toe Switch” that is located beneath the on-board pedal. This switch actually has two functions:

   • The Toe Switch can be assigned with any MIDI command, just like any other FBV Footswitch. This can be especially handy for some related Pedal-based effect parameters.
   
   • Additionally, as a fixed, non-editable behavior, the Toe Switch will toggle Pedal 1 to utilize either the “Pedal Wah” or “Pedal Vol” assignment, as configured in the Control Properties list. The WAH and VOL LED lights on your FBV unit will indicate which function is currently in use. The Toe Switch always performs this action, regardless of the settings made to the Toe Switch options in the Control Properties list.

Also see the “3 - Pedal Wah and Vol” description above for more about pedal settings.

5 - Pedal 2 (Shortboard only): FBV Shortboard MkII offers an “Expression Pedal” jack on the back where you can connect an optional expression pedal (such as the Line 6 EX-1). To edit the assignment for the expression pedal, click directly on this Pedal 2 area in the image, or directly on the Pedal 2 row in the Control Parameter list below. You can configure Pedal 2 to send any MIDI CC and value range to continuously control a “knob” or “slider” parameter in your software.
6 - Control Properties List: This list displays all editable Footswitch and Pedal controllers for your selected FBV Shortboard/Express MkII device. As mentioned in the above descriptions, you can click directly on a switch on the Device Controls - FBV Image, or click on any row here in the Control Properties List to select it and edit its MIDI settings. To follow are descriptions for each column and the options provided...

- **Control**: The static name of the physical Footswitch or Pedal, as labeled on your FBV MkII device.
- **MIDI Command**: The type of MIDI message the Control will transmit when pressed. You can choose between the following types of MIDI commands for all Footswitches (note that Pedal Wah, Pedal Vol, and Pedal 2 Controls offer only the MIDI CC and Unassigned options):
  - **Unassigned**: Sends no MIDI data. Basically, this is to disable the Control.
  - **Bank Change**: A numerical value typically used to switch through Preset Banks.

*Note: Any FBV Bank Change command always also transmits a Program Change as part of its MIDI message. This provides the behavior where the first preset is automatically recalled within the new, selected Bank. For example, if your software is currently on Bank #1 and preset #23, if your FBV Control is configured to send a Bank Change, Increment, Value 1, this results in recalling Bank #2 and preset #1 in your target software.*

- **Program Change**: A numerical value typically used to switch through Presets within a selected Bank.
- **MIDI Continuous Controller (MIDI CC)**: A set of Value and Range numbers commonly used by MIDI software and hardware to provide access to parameters.
- **MIDI Machine Control (MMC)**: Specific commands for commonly used for controlling things such as transport parameters and mechanical functions (Play, Stop, Record, etc.)
- **Mackie**: Specific commands in the “Mackie Universal Controller” format, commonly used for transport parameters and mechanical functions (Play, Stop, Record, etc.), on MIDI software that supports the Mackie Control format.

**Value**: Allows you to select a MIDI Value for the selected MIDI Command. These options differ depending on the type of MIDI Command selected (see the MIDI Command descriptions above).

- If the **MIDI Command** is **Bank Change** or **Program Change**, with either **Increment** or **Decrement** as the **Switch Mode**, you can select a value of 1 thru 10^x to provide switching through Banks/Presets by this amount per click.

  *Note: it is actually possible to select a value of “0” for the Bank or Program Change command type when set to the Increment/Decrement Switch Modes, however, this is not recommended since this is not a valid option for most MIDI applications to receive.*

- If the **MIDI Command** is **Bank Change** or **Program Change**, with **Fixed** as the **Switch Mode**, you can select any value of 0 thru 127 to switch directly to this numbered Bank/Preset.
- If the **MIDI Command** is **MIDI CC**, you can choose a value of 0 through 127, or Custom. If Custom is selected, the **Toggle 1/Up** and **Toggle 2/Down** options in this control row become selectable, so that the each Toggle action can be defined with its own separate MIDI CC value.
- If the **MIDI Command** is **MMC**, you can choose between the options **Play**, **Stop**, **Play/Stop**, **Record Punch-Pro Tools**, **Pause**, **Fast Forward**, or **Rewind**.
• If the MIDI Command is Mackie, you can choose between the options Play, Stop, Play/Stop, Record Punch, Pause, Fast Forward, or Rewind.

**Toggle1/Up Toggle2/Dn CC/Val Columns:** These columns become selectable when the MIDI Command is set to “MIDI CC” and Value is set to “Custom”. Individual values can be then be entered manually here to specify the Toggle 1/Up and Toggle 2/Down alternating switch behaviors.

**Port:** The FBV Control software MIDI Out port the data is to be sent out. The FBV MkII device offers four independent USB MIDI Out Ports that are selectable by other MIDI software on your computer to receive the MIDI Commands FBV is transmitting. You can choose Port 1, 2, 3, 4 or All independently for any Control.

**Channel:** The MIDI Channel that the data is transmitted out on for the selected Port(s). You can choose any single channel, 1 thru 16. If the you have selected “All” in the Ports column for the Control, the current MIDI Channel setting is used for all four MIDI Ports. (To change the channel number, click directly on the value and drag up/down, or use your mouse wheel!)

**Switch Mode:** The options available here are dependent on the currently selected MIDI Command. (There are no Switch Mode options for the Pedal Wah, Pedal Vol, or Pedal 2 controls.)

• If the MIDI Command is Bank Change or Program Change, the options available here are **Increment, Decrement, or Fixed:**
  - **Increment:** Sets the footswitch to increment thru Banks/Programs by the amount of 1 to 127*, as set in the Value column.
  - **Decrement:** Sets the footswitch to decrement thru Banks/Programs by the amount of 1 to 127*, as set in the Value column.

*Note: It is actually possible to select a value of “0” for the Bank or Program Change command type when set to the Increment/Decrement Switch Modes, however, this is not recommended since this is not a valid option for most MIDI applications to receive.

• **Fixed:** Sets the Footswitch action to jump to a specific Bank/Program number 0 through 127, as set in the Value column.

• If the MIDI Command is MIDI CC, the options are **Single, Momentary, or Toggle** to provide these types of footswitch behaviors.

• If the MIDI Command is MMC or Mackie, there are no selectable Switch Mode options.

**TIP for FBV Shortboard MkII:** Whenever you press a footswitch or move a pedal, the LCD display on your FBV device shows abbreviated text indicating the MIDI message sent (e.g. CH 1 CC 63 VAL 127 tells you the message was sent on MIDI Channel 1, MIDI CC 63 Command, with a CC Value of 127).

7 - **No Device Connection Status Indicator:** If no FBV MkII device is detected when you launch the Line 6 FBV Control application, you’ll see this alert at the bottom of the application window, meaning that you either neglected to connect the FBV unit’s USB cable, or there is a problem detecting the device:

```
No Line 6 device connected.
```

**TIP:** Try connecting the USB cable directly to one of your computer’s on-board USB ports rather than into a USB hub for the best connectivity.
Opening and Saving FBV Presets

The Line 6 FBV Control application allows you to create, edit and save all the current settings within the application GUI as a “patch”, or FBV preset file stored on your computer hard drive. This means you can backup the complete settings currently loaded in your FBV Shortboard or Express MkII hardware’s internal memory, or numerous customized versions of those settings, as individual FBV presets and load any one of them into your FBV’s memory at any time. Additionally, we’ve included a few FBV presets for you already. To follow are some details on how to manage FBV presets.

As mentioned earlier, whenever your FBV MkII device is USB-connected to your computer, and the Line 6 FBV Control application is launched with the device selected, the contents of the device’s internal memory is automatically loaded into the FBV Control application’s GUI. Additionally, whenever you edit any single setting in the FBV Control application, the changes are automatically written to the FBV MkII device’s internal memory. (Your FBV MkII device’s internal memory holds one complete .fbv preset file at a time).

TIP: Even though all the settings within the Line 6 FBV Control application GUI are automatically stored on your connected FBV device, it is a good idea to always do a “Save” or “Save As” of all your FBV device’s settings as an FBV preset on your computer once you’ve completed editing the settings using the Line 6 FBV Control application. This ensures you always have a “backup” of all these current settings as an .fbv preset file to return to as you edit and create other settings!

Open an Existing FBV Preset

- With your FBV Shortboard or Express MkII device connected to your computer’s USB port, launch the Line 6 FBV Control application.
- Go to the File > Open menu within the application.
- By default, this should open to these directories:
  - Mac® - Documents/Line 6/FBV/Presets
  - Windows® - My Documents\Line 6\FBV\Presets
- In the above directories you will find the “factory” FBV Presets we’ve included (e.g. - “FBV-Default.fbv”).
- This is also the default directory where you will be prompted to Save your own custom .fbv presets.
- Opening one of these .fbv preset files loads all the assignments into the FBV Control application’s GUI and automatically loads the full preset into the internal memory of your FBV MkII device.

Note that your FBV Shortboard/Express MkII device holds one complete FBV preset at a time. When opening a new preset file as described in these steps, it will REPLACE all the USB MIDI Control assignments in your FBV device’s internal memory with those from the newly opened .fbv preset file. Before opening a new preset file, you may want to do a Save or Save As of the current preset to your computer if you want to be able to recall these settings again later.
Saving an FBV Preset

While working in the Line 6 FBV Control application, at any time you can Save all the current settings within the Control application's GUI as an FBV preset file to your computer's hard drive. It is a good idea to do so whenever you have a set of commands you don't want to forget so you can load them into your FBV device later on (remember the mantra - "Save early and Save often"!)

Following the typical Mac® and Windows® software conventions...

• To Save the changes made to the current FBV Preset, overwriting the previous settings of this file, choose File > Save form the application's menu.

• To Save the changes made to the current FBV Preset as a new FBV Preset file, choose File > Save As from the application's menu. You'll then be prompted to name the file, and where to save it. To keep your FBV Preset files tidy and easy to find, you probably want to always save them in the directory where we already stored the factory presets during installation:
  - Mac® - Documents/Line 6/FBV/Presets
  - Windows® - My Documents\Line 6\FBV\Presets

TIP: You’ll see the name of your currently loaded preset appear with an asterisk following its title (e.g. - “My Preset.fbv*”) at the top of the application window whenever the preset is in an “unsaved” state.

Editing and Saving FBV Presets with No Connected FBV Device

Another possibility worth mention here is that you actually do not need to have your FBV Shortboard/Express MkII device USB-connected to run the Line 6 FBV Control application to edit or save preset files. You can still use the above steps to Open, Save or Save As FBV presets on your computer. You might find this handy if you just want to do some edits or look over the settings of the FBV preset files stored on your computer without also loading the Preset into your FBV device's internal memory. To load any of these presets into the internal memory of your FBV MkII device, you'll need to connect the FBV to your computer's USB port, and then open a saved FBV preset as described above to have it auto-load into your FBV device’s memory.

When you launch the Line 6 FBV Control application without an FBV MkII device connected, you will need to instruct the application what type of device model format (Shortboard or Express MkII) to work in. This provides the perfect segue to the next section, where we'll look at these options in the application Preferences!

Preferences

As is the case with most other software applications, we’ve placed a few of those more “geeky” settings away in the Preferences. To get to the Line 6 FBV Control application’s Preferences dialog:

• Mac® - Line 6 FBV Control > Preferences
• Windows® - File > Preferences
FBV Device Type Prompt

When no Line 6 FBV device is detected at startup, the Line 6 FBV application has the option of displaying either an FBV Shortboard or Express MkII device configuration for its GUI. By default, you'll always be prompted on startup with a dialog to choose which you prefer. If you do not want to be prompted, select the preferred device here. Alternatively, you can check that little “Do this every time” box at the bottom of the prompt dialog itself to set this behavior, and you can change it here in the Preferences any time.

Note that this does not affect how the Line 6 FBV application launches when your FBV MkII device is connected - it will automatically show the GUI for the connected FBV device type. Further, if you have more than one FBV MkII device type connected to your computer at the same time, (such as both a Shortboard and Express MkII), then you'll be prompted to select which you want the Line 6 FBV Control application to work with.

Show Warning Dialog at Startup

This checkbox refers to that dialog that pops up when Line 6 FBV Control application starts, informing you about the important, automatic behavior where the changes you make within the software have instant effect on the memory stored within your connected FBV device (sorry to nag you, but it really is important!). If you don’t want to see this warning, then you can uncheck this box here in the Preferences. Or, if you’ve hastily checked that “Don’t show again” box in the prompt dialog itself but want to the reminder back, you can come to the Preferences and check this box here to have the prompt appear again. Just promise you’ll read the message before turning this off, OK?
**Using Your FBV with Software Applications**

With the information in the previous chapters, you should now be ready to put your FBV Shortboard or Express MkII device to work to remotely control your favorite software applications! We’ll cover just a few tips on how to configure other software applications to communicate with your FBV MkII device.

**About USB MIDI Ports & Channels**

When connected to the USB port of your Mac® or Windows® computer, your FBV MkII device establishes one USB “MIDI In” port and four USB “MIDI Out” ports on your computer*. These are not “physical” hardware ports that require you to use a mess of MIDI cables - your FBV communicates all its MIDI data across your USB cable to these “virtual” software MIDI ports. You’ll be able to access these FBV MIDI Ports within the Options or Preferences settings of any software on your computer that supports MIDI communication.

*Note that these FBV USB MIDI In and MIDI Out port names appear differently in your MIDI software depending on your computer’s operating system - See the following Ableton Live® setup for an example.

**Setting your Software to Receive Communication from your FBV MkII MIDI Port**

Typically, you’ll just want to set the software application that you want to control via your FBV to receive MIDI control data from the MIDI Out port and MIDI channel to which your FBV device is transmitting its data. For example, in the Ableton Live® or Live Lite® software, the Preferences > MIDI/Sync dialog offers options to choose one or more MIDI controller devices. In your MIDI/DAW software, you’ll see FBV MIDI Ports 1 through 4 from which to receive MIDI Control data.

Note: Exactly how these four ports are titled is slightly different under Mac® OS X, Windows® Vista® and Windows® XP® - Please see the setup example in the following GearBox software section for an example.

By default, all your FBV MkII Control assignments are transmitted to the FBV MIDI Out Port 1. However, you can set any individual FBV Control to transmit its MIDI control data to any FBV MIDI Out port 1 through 4 (see the Control Properties List section page 2•3).

**Windows® MIDI Port Communication**

It is important to note that the Windows® USB Class Compliant driver, which is used for your FBV MkII device on Windows® Vista® and XP®, inherently will not allow more than one application utilize one USB MIDI port at a time. The Line 6 FBV Control application, when open, uses the FBV MIDI In port and the MIDI Out port 4 for communication with your FBV device. Therefore, if you have another MIDI/DAW software application also currently running on your Windows computer that is configured to also use these same FBV MIDI ports, only one application will be permitted to do so.

If you already have your MIDI/DAW software running, and it has the FBV MIDI In port enabled, trying to then launch the Line 6 FBV Control application will typically result in the FBV Control application failing to detect the connected FBV device, since it is “in use” already by the other software. One possible solution is to disable the use of the FBV MIDI In port and FBV MIDI Out 4 port within your MIDI/DAW software to permit you to still use it while also using the FBV Control application. (You should be OK keeping the MIDI/DAW software enabled for receiving from the FBV MIDI Out ports 1 through 3, which allows you to still send MIDI Control commands from FBV to your software).
Otherwise, you should exit all other MIDI/DAW applications when using the FBV Control software to provide full MIDI port access to the FBV Control software for editing your FBV control settings.

Note: The Line 6 Monkey application also utilizes the FBV MIDI ports for its ability to detect and update your connected FBV device. It is always recommended that you exit the Line 6 FBV Control, as well as any MIDI/DAW software, before launching Line 6 Monkey.

**MIDI Channels**

Each USB MIDI Port carries 16 MIDI “channels”. You can think of MIDI channels just like channels on your TV - your TV is capable of receiving many “channels”, but you’ll only be able to see the program you want to watch if you tune your TV set to the specific channel. Same thing here in the world of MIDI. By default, your FBV MkII device will transmit its MIDI data to Channel 1 on the selected MIDI Port for each Control. However, you can set any individual FBV Control to transmit its MIDI control data to any MIDI Channel (see the Control Properties List section on page 2•3). You may find that your software offers options to receive only on a specific MIDI channel from the selected MIDI port, so you will want to be sure to configure any such MIDI Channel options to match those on which your FBV Controls are transmitting. Consult your software’s documentation for info on its MIDI Channel options.

**Line 6 GearBox Control**

If you use GearBox, you’ll be happy to know that most all amp and effects parameters in the software are capable of responding to MIDI messages from an external MIDI controller. This means your FBV MkII is just the hardware to take control!

Note: It is recommended that you have GearBox 3.7 version (or later) installed for use with FBV MkII. To get the latest version, just run Line 6 Monkey with your Line 6 USB audio hardware connected (POD Studio, TonePort, GuitarPort, POD X3, PODxt) and allow Monkey to point you to the necessary download.

To configure GearBox to receive MIDI Control data from your FBV MkII device, go to the GearBox Preferences > MIDI/Control dialog and set the “MIDI Input” option to receive from the desired FBV MIDI Out Port, as shown here. Note that you’ll see the four FBV MIDI Out ports named differently, depending on your computer’s operating system:
As shown above, there are four FBV MIDI Ports to choose from, so you'll want to be sure to select the same FBV MIDI Out port that your FBV is transmitting to. By default this is the first selectable port in the list. You can check and edit your current FBV Control MIDI port assignments using the Line 6 FBV Control application.

**Note:** On Windows XP, the FBV MIDI ports appear as “USB Audio Device” - This is normal and just a function of the Windows Class Compliant USB device driver. These are indeed the FBV USB MIDI Out ports 1 thru 4.

GearBox always receives MIDI data on Channel 1, so you'll also want to set your FBV Controls to all transmit on this MIDI Channel. As mentioned in the **Getting Started** chapter, just load the GearBox FBV Preset onto your FBV MkII device by way of the FBV Control application's File>Open menu and this will configure a very useful set of Control assignments for use with GearBox!

TIP: For a handy reference of all the MIDI CC assignments for GearBox parameters, please download the Line 6 MIDI CC Reference document from the Line 6 FBV MkII Online Help page.

**Controlling 3rd Party MIDI/DAW Software**

Most popular music-oriented software these days includes some level of support for controlling its parameters remotely via MIDI control messages, just like those your FBV MkII device is capable of sending. The first step is to configure your software to receive communication from your connected FBV MkII device's USB MIDI port - see the above **USB MIDI Ports & Channels** section. The next step is to configure your FBV MkII to send the necessary MIDI commands to control the desired software parameters. Some MIDI and DAW applications make this all pretty easy, while others require more manual settings to access their parameters via MIDI.

**MIDI Learn Functionality**

Many applications now offer a handy “MIDI Learn” functionality, where you click on the desired knob/slider/switch in the GUI of the software to place it in a “Learn” mode and then simply access the control on your FBV MkII device and the software instantly maps the FBV switch/pedal to control the selected parameter. For example, Propellerhead Reason and Ableton Live applications provide exactly this type of functionality for most of their parameters - including their transport buttons, track options, and even their synth & effects parameters!

For applications that offer this “MIDI Learn” capability, you'll want to be sure that your FBV MkII footswitch and pedal controls have MIDI commands assigned so that the target software has something to “learn”. You can typically set each FBV MkII control to send a different MIDI CC command and the software will utilize this communication with FBV. To configure these settings, you can of course use the Line 6 FBV Control application's Control Properties List options (see page 2•3), or try loading the “FBV-Default.fbv” preset we've provided as a starting point. Please refer to your MIDI or DAW software's documentation for specifics on configuring MIDI Control devices and parameter assignments.

**Manual MIDI Control Assignment**

For applications that do not offer a “MIDI Learn” feature, then the process is more of a manual one, where you'll need to acquire MIDI reference documentation form the software manufacturer that lists specifically what MIDI Commands and Values are already set for the parameters within the software.
Most often, applications utilize MIDI CC commands for their parameters, Program Change commands for switching patches, and sometimes MMC or Mackie commands for transport buttons. With the manufacturer's MIDI reference documentation in hand, you can then use the Line 6 FBV Control applications to “map” your desired FBV Footswitch/Pedal controls to match those that your software's parameter MIDI assignments.

Please also see the FBV MkII Advanced User Guide and other MIDI documentation available on the Line 6 FBV Online Help page for more about setting up MIDI Control with 3rd party software.
**Line 6 Monkey & Additional Resources**

Line 6 Monkey is the intelligent updater utility automatically installed with your Line 6 FBV Control application. It is highly recommended that you run Line 6 Monkey at the end of your Line 6 FBV Control application installation, and to do so often to be sure you have the latest updates for all your Line 6 software and hardware products. Registering your Line 6 hardware is also very important because it ensures that you’re dialed in for warranty service and makes it possible for us to contact you if new software versions or other cool enhancements are offered - cutting edge technology and such! So don’t put this off any longer.

Once you’ve installed the Line 6 Monkey software, connect your FBV MkII to your computer’s USB port (and please disconnect any other Line 6 USB devices for now since we only want Line 6 Monkey to check your FBV). Be sure to exit the FBV Control application as well as any MIDI/DAW applications that might be running. With your computer’s Internet connection active, follow these steps to launch Line 6 Monkey...

- **On Mac**, go to Applications > Line 6 > Line 6 Monkey
- **On Windows**, go to the Start button menu > Programs > Line 6 > Tools > Line 6 Monkey

**Login Account**

You’ll need to Login so that Line 6 Monkey can communicate with the online Line 6 Server and provide you with exactly what you need. It’s just a few clicks, and it’s free!

- If you have a Line 6 account, then type in your User Name and Password at the top of the Monkey dialog.
- If you have not yet created an account, click the New User button and you’ll be walked right through the steps.

**Register Your Hardware**

If you have not already done so, you’ll be prompted to Register your connected Line 6 hardware. You may be required to register your FBV MkII to be able to perform some upgrades or product activations. It’s a painless process really, so click that Register Now button and fill in the blanks on the Web page. This page will list all your registered Line 6 gear in one place.
Grab Those Updates

Once Line 6 Monkey launches, it will automatically detect your connected FBV MkII device. On the Updates page in Line 6 Monkey, if you see any items where a newer version is available, then you should click on that item and let the little monkey fellow walk you through the installation steps. This is the easiest way to stay current on the latest Line 6 software and hardware updates.

Flash Memory Update

If Monkey tells you there is a newer Flash Memory version available then it is important that you install it for the best performance and product compatibility with your FBV. Just follow the steps as Monkey instructs you, including these important tasks:

- Exit any Line 6 or 3rd party MIDI/DAW applications that might be using your FBV MkII device.
- Be sure not to press the buttons, move the pedal, or change any cable connections on your FBV device until the update process completes.
- Once Line 6 Monkey tells you the update was successfully completed, exit Line 6 Monkey and launch it again to see if any additional updates might still be available.

Additional Resources

Hungry for more info? We’ve got plenty of helpful resources just a click away...

- Additional Help documentation covering the latest FBV MkII product & MIDI Reference info is available here:
  FBV MkII Online Help

- For technical support, choose from the many options listed on the Line 6 Support, including the searchable Knowledgebase:
  Line 6 Support

- Can’t get enough of that Line 6 Gear, or want to check out the latest accessories? Head on over to the Line 6 Store!
  Line 6 Online Store

- Join the Community! Pay a visit to the Line 6 Communities page, where you can find:
  - Free iTunes® and MP3 Jam Tracks.
  - Free loops for GarageBand®, Acid®, Reason® and more.
  - Free guitar lessons from LA session pros.
  - Free chord and scale practice tools.
  - Information about contests and special offers.
  - Access to discussion forums, software updates and more.
  Line 6 Communities